2 posts Page 1 of 1
Postby phanosh » Thu Sep 17, 2015 8:07 pm
I just received my t450s and im trying to download some software which are offered by Neptun. Each time I try to go to thee site download.ethz.ch and try to login with my credentials I get a warning sign saying that the website is unsafe! Even when I clicked continue and tried to download Sophos Antivirus it would start and then stop abruptly.
Postby simon-ses » Fri Sep 18, 2015 11:57 am

The warning about the outdated certificate of the website is because we are currently evaluating a new solution and therefore didn't buy a new certificate for the moment. This should not be causing problems.

I just tried and the Windows installer for Sophos downloaded correctly in just a few seconds (it is only 5.8 MB).

Also the Mac Installer downloads without trouble for me (takes about 1 min. for the 134 MB).

Please make sure that your internet connection is stable while downloading so it is not interrupted.

Best regards,
2 posts Page 1 of 1


Who is online

Users browsing this forum: No registered users and 4 guests