1 post Page 1 of 1
Postby BirrerEd » Fri May 27, 2011 3:09 pm
Hab seit Herbst 2009 einen W500 und heute Upgrade von Ubuntu Linux 9.10 auf Ubuntu 10.04 laufen lassen. Nun haben dort alle Fenster keine Rahmen mehr, ich kann sie nicht mehr vergrössern/verkleinern/schieben. Dies auch nach mehrmaligem Neustart von Linux.

Bis gestern hab ich diese Kiste problemlos betrieben mit Windows XP und Ubuntu Linux 9.10.
Allerdings kenne ich das Fenster-Phänomen, es trat immer auf, wenn ich zuletzt auf Windows gearbeitet hatte. Ich musste ich immer 2x booten, wenn ich das Betriebsystem wechselte, damit die Grafik korrekt funktionierte.
Nämlich:
Wenn ich zuletzt auf XP gearbeitet hatte und dann Ubuntu benutzen wollte, hatte ich genau die Fehler, die ich jetzt habe: alle Fenster haben keine Rahmen, ich kann sie nicht verschieben und nur über das Menü schliessen (weil es keine Knöpfe hat).
Nach einem erneuten Start auf Ubuntu funktionierten die Fenster bestens, ohne dass ich irgendwo etwas umgestellt hätte.
Und wenn ich zuletzt auf Ubuntu gearbeitet hatte und dann XP benutzen wollte, gab es Fehler von der Art \"Es ist kein ATI-Grafiktreiber installiert oder der ATI-Treiber funktioniert nicht\".
Nach einem erneuten Start auf XP funktionierte die Grafik bestens, ohne dass ich etwas installiert oder umkonfiguriert hätte.

Offenbar hat der W500 ja 2 Grafikkarten (ATI Mobility Radeon HD 3470 256MB / X4500HMD). Im BIOS ist bei Display eingestellt: Switchable und Autodetect.
Vielleicht wurde jeweils nach dem Start jeweils der Grafikmodus umgestellt, aber galt erst für die nächste Session. Hab das nie untersucht.

2x booten ist zwar unbequem, aber immerhin funktionierten beide Systeme. Nun hab ich wie erwähnt Ubuntu 10.04, und ich kann booten sooft ich will, die Fensterrahmen erscheinen nie.
Hab auch mit dem BIOS-Setting rumgespielt:
Autodetect off und dann bei \"Integrated\" das obige Phänomen, bei \"Discrete\" startete der Spash-Screen bei seltsam grob-graumeliert und wurde immer weisser, bis er so hell war, dass ich Angst um den Bildschirm kriegte und mit Druck auf Powertaste das Ganze abbrach.

Wie krieg ich jetzt die Fenster in Linux zum Laufen? Und möglichst so, dass auch XP weiterhin funktioniert?
Mir ist auch egal, wenn ich weiterhin 2x booten muss, wenn ich das System wechsle. Hauptsache, beide Systeme laufen.

Bin dankbar für alle Tipps! Am liebsten nicht allzu experimentelle - das Ubuntu ist mein Haupt-System, möchte es nicht \"kaputtkonfigurieren\"!
1 post Page 1 of 1

Login

Who is online

Users browsing this forum: No registered users and 1 guest

cron